Migration not working in CMD and also gitCMD

hy i am new to yii2 framework and started learning api but when i am doing the migrationg use the my CMD or the other inbuilt terminal of IDE’s it just not asking taking my command yes or no it just further

as this image shown in i run command in CMD

and this image is from PHPSTORM it also not working

in simple words it not taking user command yes and no and go further command before this it aksing me to enter yes or no and one i typed no from that time its not working properly

You can try adding --interactive=0 to the command. It would not ask anything. But overall it seems you’ll need something like https://gitforwindows.org/ console in order for it to work properly.


wow sir @samdark it worked it solved my problem i just wasted my 2 days in this problem finding solution on youtube and stackoverflow but finally i got answer from you and yii forum and i am checking this given console thank you

Feel free to ask around at these forums. That’s whay they are for.

hy @samdark i amtrying to install yii2 advanced to try api in advance so i got problem like this in git console and it aslo same occur in other command prompt


it just not give me a option to type 0 or 1
i also types this --interactive=0 after command but its not working

Well, that is super-weird. Using Windows 10 myself and never encountered it :frowning:

@samdark yeah mine is window 8.1 i think i should upload my windows after internship

@fezzymalek Let us know if you was successful in updating your PHP (or reverting to a previous version), as mentioned in another thread you visited.

no i dont revert version in php i just typed this for migration

php yii migrate/create post --interactive=0

Migration not working in CMD and also gitCMD as @samdark suggested