Advanced template init

Could you help me please, I’m beginner.

Install the advanced version using composer and when I try to run the php init command, it stops and I don’t know what happens.

Go for development

One more user seems to have the same problem.

1 Like

yes bro it still not working maybe my windows problem i will soon update my windows

1 Like

Thanks, I had to migrate a finished installation, with the files initialized.
In Win 10 it doesn’t work.

yes @arturosy i learned basic template but i started to learn advance template and this error is happened with me so right now i am unable to learn advance template

Perhaps try a fflush(STDIN) before the first fgets(STDIN) in the init file (top of file)?
(Btw it looks like both of you are using Wamp64?)

This obviously was a bug in php 7.4. Try updating or revert to a previous version.

Thks, I’m going a try with other version.

no its not working i tried in both 5.4 and 7.3 version it still not waiting for yes or no

1 Like

The init.bat batch file for the 2.0.35 advanced template is not working correctly. It should pause and allow the user to choose ‘0’ for ‘Development’ or ‘1’ for ‘Production’. The batch file skips through the selection part, preventing some of the configuration files from being created.

2.0.35 was released on May 2, 2020 and it is now July 4, 2020.

As it turns out, it’s not the init file. The PHP 7.4 version installed with WAMP64 does not launch the init correctly. Had to revert to PHP 7.3.12 to get the init file to generate the configuration files.

I wouldn’t say “It turns out”. Glad you solved it.

BTW A bug in 7.4.0 that is.