Suite 'common, frontend, backend' could not be found

Hello.
Sorry for bad English :frowning:

Install yii2 advanced from rep https://github.com/yiisoft/yii2-app-advanced

System: ubuntu 18.04.
Configuration with vagrant 2.2.6.

Virtual machine work fine.
Frontend and backend successfully open in browser and work fine.

First tried to run default tests with Codeception PHP Testing Framework v4.1.4.

“codeception.yml” in main folder and common/frontend/backend folders set by default.

Try run it with PhpSrom (use remote PHP interpreter settings) use his codeception tools.

Also try it directly at virtual machine (use ssh) with:
$ vendor/bin/codecept run
or
$ vendor/bin/codecept run – -c frontend

The result is always like this:

> Codeception PHP Testing Framework v4.1.4
> Powered by PHPUnit 8.5.3 by Sebastian Bergmann and contributors.
> Running with seed: 
> 
> [common\tests]: tests from /app/common
> 
> [frontend\tests]: tests from /app/frontend
> 
> [backend\tests]: tests from /app/backend
> 
> In Run.php line 406:
>                                                        
>  Suite 'common, frontend, backend' could not be found  

Help please.

Looks like it can’t find your suite. Try absolute path or ./vendor/bin/codecept run.

The problem has not yet been solved. Anyone have any ideas?

" ./vendor/bin/codecept run - nothing changed

Do you suggest using absolute path in codeception.yml?

I don’t have Vagrant installation so tried with local PHP:

  1. composer create-project --prefer-dist yiisoft/yii2-app-advanced yii-application.
  2. cd yii-application.
  3. ./init, select development.
  4. ./vendor/bin/codecept run.

It was able to find all tests. So either that’s vagrant-specific or one of the steps you’re doing is different.

Yes, it’s vagrant-specific problem. Without vagrant tests run successful.

I’m using Laravel Homestead (Vagrant + Ubuntu 18.04).
Codeception works well for me, both ./vendor/bin/codecept run and ./vendor/bin/codecept run -- -c frontend.
By the way, my Yii version is 2.0.34.

I have the same problem.
And also, without Vagrant the tests run successful.