Celestic


(Erling Fiallos) #1

Hi guys, wanted to share our first Yii application called Celestic.

Celestic it’s basically an application to keep track of any software project that was being developed. I know there are many similar services online, but there was none that was only to keep track of software projects and all metrics … Also most of these services are not free and those who are not allowed to download for use on its own servers. With Celestic you can handling unlimited projects, users, companies and clients, tasks and task lists, registration of documents and milestones, managing individual permissions for users and modules, progress activity reports, searches in the different modules and email notifications and more… (thinks I cant remember now) :D

The code is available in the repositories of Google Projects, can also follow the blog to find out who’s next or report any problems from the forum.

Thanks to Yii Dev Team… Happy coding!!

[twitter]jackfiallos[/twitter]

http://qbit.com.mx/labs/celestic

http://code.google.com/p/celestic-community/


(Imehesz) #2

very nice looking site! keep it up!

–iM


(Erling Fiallos) #3

thanks imehesz …

with some extra time, greatly improve


(W3bdam0n) #4

I’ve got this message right after visiting celestic for the first time, never saw installation screen :(

[b]


(Cr930) #5

Wow! Nice job!

I like the beaver too! His tail should be almost black though :)

Looking forward to installIng this!

Hopefully you’ll be as or more famous than redmine!


(Jsfousseni) #6

What is the demo account?


(Cr930) #7

How do you install?

Do I have to migrate the db or something?


(W3bdam0n) #8

I couldn’t install it, I guess, there should be an installation script, which runs when you visit Celestic on your host for the first time.


(Cr930) #9

I’m getting a db connection string error. :(


(W3bdam0n) #10

just edit the config

celestic\protected\config\db.php

I never got db error even if I put wrong settings :lol:


(Cr930) #11



<?php


$db = array(

	'components' => array(

		'db' =>  array(

			'class' => 'CDbConnection',

            'connectionString' => 'mysql:host=localhost;dbname=celestic',

			'emulatePrepare' => true,

			'username' => 'root',

			'password' => 'root',

            'charset' => 'UTF8',

            'tablePrefix' => '',

            'emulatePrepare' => true,

            'enableProfiling' => true,

            'schemaCacheID' => 'cache',

            'schemaCachingDuration' => 3600

		),

	),

);


return $db;



Can’t make mistake with only this :(


(Cr930) #12

Ok, looks like I’m a noob, well I am a noob to yii.

I installed the celestial by:

  • putting Yii into the main folder (could probably just point to where it is located on your server)

  • edit the db.php config file (I posted that above)

  • got the db files out of protected/modules/install/data (install schema first ;) )

  • edited production.php // I commented out the db array (from about line 20 to 29 )

  • refreshed site

  • logged in with the preset information

Still have to see if I can relogin without setting the password.

I like what I see so far!

One thing to add: you should change the db from Latin1 to UTF8

#$# %&’$

the install link looks like this:

www.site.com/celestic/?r=install

UGHH!!!!!!

hmmm, installer died at:

celestic/?r=install&step=3&auth=(token)

Adding edits so don’t mind the gibberish.

Looks like i was trying to install the app on the celestial site … LIke how the F$%# did I get there? Thank goodness the installer died!!!


(Cr930) #13

update:

if the installer doesn’t work try the above steps I posted earlier.

I was able to create a fresh account and things seem to be working :D


(W3bdam0n) #14

congrats man, you did it!

but, as I said, I never got to the db connection, here is the screenshot


(Cr930) #15

Hi!

Looks like you should download a fresh zip and then follow what I posted above.

I guessing from the error that somehow files are missing or not being called.

Another off the wall possibility I normally check for is line endings. Are they windows type or *nix type.

I’m on OSX so I use UTF-8 / Unix LF file encodings.

And check for if there is a final return at the end of the file or not.

I’m not familiar with XAMP on windows but if you’re jumping between environments you might have pooched a file with Window’s encoding and line endings and then moved them to XAMP. I have the opposite problem. I have to convert window’s files to *nix to get things to work at times.

Also you need to do an extra step that I didn’t post above.

the db.php doesn’t seem to being called on my install … I still need to trouble shoot that.

change your production,php to


// Production configurations

$production = array(

	'components' => array(

/*

		'db' =>  array(

			'class' => 'CDbConnection',

			'emulatePrepare' => true,

			'charset' => 'UTF8',

            'tablePrefix' => '',

            'emulatePrepare' => true,

            'enableProfiling' => true,

            'schemaCacheID' => 'cache',

            'schemaCachingDuration' => 3600

		),

*/

		'db' =>  array(

			'class' => 'CDbConnection',

            'connectionString' => 'mysql:host=localhost;dbname=celestic',

			'emulatePrepare' => true,

			'username' => 'root',

			'password' => 'root',

            'charset' => 'UTF8',

            'tablePrefix' => '',

            'emulatePrepare' => true,

            'enableProfiling' => true,

            'schemaCacheID' => 'cache',

            'schemaCachingDuration' => 3600

		),


		'log' => array(



Since I’m still new to Yii I have no idea how to switch between dev and production modes so I just forced the production mode to call my db directly.

I like what I am seeing here so I’ll try to debug more and try to get the installer working properly.

here’s my machine stats:


Celestic version:0.3.5

Server Apache: Apache/2.2.21

Plataform: PHP 5.3.8, MYSQL 5.1.40

Good luck dude!


(Erling Fiallos) #16

Hi Vit78

This is a common mistake from php developers and IDE’s that we use … I saw $selected variable isn’t initialized… but it’s used, then you have a warning message… just add in protected/config/production.php file “error_reporting(0);” at the begining …

Remember to set YII_DEBUG false or delete the lines in index.php folder root.

In the next version of celestic this kind of bugs are fixed.


(W3bdam0n) #17

he he, thanks guys! disabling error reporting and changing db settings in production.php helped.

now it works great! my next step is to force it to run in debug mode as well. usually Yii apps work OK on my localhost in debug mode and I’d like to see every error and notice, even strict. that’s just me, I run apps in ‘discovery’ mode and I’m sure for the 100% of end-users Celestic is fine.


(Erling Fiallos) #18

That’s ok Vit78 … if you find something wrong please let me know … I’m sure that’ll fix it quickly …


(Erling Fiallos) #19

I uploaded Celestic 0.4.0 you can download from https://code.google.com/p/celestic-community/

Remember to use the latest version of Yii

Comments and suggestions always welcome :D


(W3bdam0n) #20

great news! I would be the first community user))

I see you chose Magento way with community edition B)