All the wordings in Messages/yii.php change to "????"

Hi all,

I have got a problem and cannot find any solution by google.

My website is working fine before. However after the hosting migration process, my website got this problem.

I am using utf-8 for my chinese website. All the Chinese words are working fine, except all the translation in the /messages/zh-tw/yii.php shown as “????”.

I have tried to change the translation as default, so the English is working fine. It looks like the wordings in the translate file is not able to be decoded by utf-8 (even the file is saved as utf-8 format).

Any idea on this problem?


All the Chinese wordings in /messages/zh-tw/yii.php shown as QUESTION MARK

I guess that your "/messages/zh-tw/yii.php" file in the new server might be broken.

Would you try re-upload it with binary mode?

Thank you for your reply.

I have tried to re-upload it in binary mode, but still cannot solved the problem.

Um, it’s strange.

You say that the hard coded Chinese texts in your app get displayed normally but the system translation messages of yii are not … am I right in understanding your problem?

Are you sure that your app with Chinese texts are saved in UTF-8 and not in Big-5?

Yes. It is totally the case. I even re-upload the original file in zip format and cannot solve it.

The translation messages are normally cached.

Clearing all the cache contents (maybe in /protected/runtime/cache) might solve the problem.