yiic weird behaviour


everytime I execute yiic with any parameter it doesn’t show any messages at all. They appear right after I type requested option (like Yes/No). I tried to use new PHP version (5.2.7) instead of 5.2.4 and all worked fine, but then I rebooted and everything went same wrong way :(.

Could you please help me?

well ok, could you pleae give more detailed information about your php installation.

i use MAMP in favor of the builtin php, so there are all my extensions installed i need for proper use of yii.

Since you mentioned you installed new php and it worked and then after reboot it does not work anymore i suspect your yii just uses the "wrong" php

You my look :

whereis php

this is the php yii should use as default, for me this way it does not work the same way, so i use following workaround:

I changed the first line of the yiic script to


instead of the original

#!/usr/bin/env php

so of course your php 5.27 might be under different location

according to your PATH environment Variable (loaded into your shell)

I dont have MAMP, I seriously doubt it would work under Windows :D.

I use PHP version 5.2.7, because when I type "php -v" in command line it shows this version, not the old one. I simply renamed the old PHP folder and then unpacked new version into folder named as the old have, then replaced some dll files in Apache directory, but I believe it has nothing to do with my Apache, because yiic uses CLI version of PHP not the module one.

my computer specification

  • Windows XP

  • Apache/2.0.55 (Win32)

  • all of browsers :)

  • Yii version 1.0.0

Well, maybe I'm dumb, but I haven't found any informations about PHP configuration for yii, so that's the reason it doesn't work.

If “output_handler” is set to any function in PHP.ini, yiic won’t print any output until it finishes it’s script, so it has to be empty.

Tnx for help  :P