yiic shell not working (windows xp)

In my <webapp> folder I have folders ‘protected’ and ‘framework’.

In command prompt I navigate to: cd "C:\xampp\htdocs\webapp"

I then type in php protected/yiic shell

But nothing happens. I just get a blank line, followed by command prompt again. No error message.

I have another webapp and the yiic shell works OK with that. So I know it’s not an environment/path setting issue.

I have also compared the config files for both the webapps and they are identical.

Anyone have any suggestions on what else could be causing this problem?

I read in some other post that restricted access to the default controller could lead to similar behavior. Try adding the config file as second parameter to yiic.


Try this one…it will work

"protected/yiic" shell

Not sure how to do this…

Does not make any difference…

Any other ways I can debug this to find out what is wrong?

OK I’ve found out the cause of the problem. In my SiteController I have the following:

public function actionIndex()




If I change this to:

public function actionIndex()




The yiic shell now works fine. But I prefer to redirect the users to index.php?r=admin in the default action. How can this be achieved without causing the yiic shell to break?

(‘admin’ is an action in another controller)

Anyone got any idea?

para ejecutar el SHELL en Windows a mi me funciono de esta manera

C:\wamp\www\WebEjemplo\protected>yiic shell ../index.php

thanks, this helped, but for me this worked:

C:\wamp\www\myproject > C:\wamp\www\yiiRoot\framework\yiic shell