Yiic shell Error: 'Moved temporarily'

  • operating system: Ubuntu 9.04 (2.6.28-14-generic) / Debian, both on i386 arch.
  • Web server: lighttpd_1.4.19-5ubuntu7_i386 (php on f-cgi)
  • Yii version or SVN revision: Problem occured a few times on several versions, stable branch and SVN co’s.


I’ve experienced this problem a few times trying to use the yiic shell. All paths seems to be perfectly fine, i cannot spot any errors there.

The problem seems to be that yiic cannot find my index.php and is receiving a 302 error. This is the output from my console:


 ./yiic shell ../public/index.php

 Status: 302 Moved Temporarily

 X-Powered-By: PHP/5.2.6-3ubuntu4.1

 Set-Cookie: PHPSESSID=35915df288e523c6d2256709770ed407; path=/

 Expires: Thu, 19 Nov 1981 08:52:00 GMT

 Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0

 Pragma: no-cache

 Location: http://localhost/login

 Content-type: text/html



Even using a full path like “./yiic shell /var/www/project-name/public/index.php” won’t work either.

I have ownership and even with 0777 mode on all dirs and files i keep getting this error. Running the command as root doesn’t work either.

Worth to mention is that i’m using rewrite rules in lighttpd for sefurl’s, i tried disabling it but it didn’t help me.

I’m very attached to the console, i love it so much that it hurts me a lot not being able to use it. /cry

I’m grateful for any input on how to solve this problem!


You may use the alternative form of starting yiic:

protected/yiic shell protected/config/main.php

Great! That worked, thank you!