Yiic shell doesn't start anymore


my Yii application (projcontrol is the app folder name) was set up and worked fine last friday.

I use alternaterbac, so have to work with yiic shell a lot. Everything was just fine, and today when i try to start yiic shell, nothing is happened

i run

it «thinks» a moment and then returns me to console

and no yiic shell open

though if i run

it shows me help…

path to php.exe in yiic.bat is set as

maybe someone can help me with this?


UPDATE: i’ve configured system Path variable and try to start yiic shell as described here http://www.yiiframew…doc/cookbook/3/ but result is the same as before


I have the same problem. I solved that in access rules I allowing access by all users to index action.

Thanks for quick answer.

Do you mean SiteController index action?

I dont use rbac in site controller.

I had the same problem. The reason was, that i made the application's default action only accessible for logged in users. I don't know of any workaround except disabling access rules while i want to work with yiic shell.

Gotcha! Yea, i think thats it! can't check up right now, but will report later. Thanks a lot!

Since 1.0.4, you can use the following command to start shell:

yiic shell path/to/config-file

yes, i know, but this didnt work too

Very nice Qiang, thanks. :)


You could use another config file for your console app and e.g. set another default (dummy) controller that doesn't restrict acces to its default action.

Thank you all, guys! i have changed default controller in config to the rbac using controller, and thats the reason. i'd never get it by myself without your help. btw i'd like to know if this feature is represented in any FAQ? if no — maybe it'll be nice to add it there?