Yii2 stuck on "installing dependencies"

I don’t know why but it always stuck on this and won’t install it till the end

How long has it been stuck? Composer can take a while to install the required packages if they’re not cached.

more than hour

Try adding --prefer-dist

Still nothing, not sure what could be wrong

Can you show us the composer.json file?

It’s hard to know why it’s not installing when we don’t even know what is being installed.

This is error I’m getting right now

Have you installed composer asset plugin ?

composer global require "fxp/composer-asset-plugin:1.0.0-beta2"

yep I did, beta3. It always stuck in different place

Looks fine to me.

Mine looks like that (except I’m using advanced template) and it update just fine.

I’m going to reinstall my site to check installation.

Ok well my last resort (if it doesn’t work well then I don’t know what to tell you)

  1. Clear composer cache

composer clearcache

composer global clearcache

  1. Delete the content of your vendor folder

// If you are on linux

cd path_to_your_project/vendor

rm -rf ./* // if you are on linux.

// If you are using windows just delete that crap with the graphical explorer

  1. Now everything should be clean.

  2. init a dev environement

  3. composer install (pray that it works)

Thank you guys, I give up. I can’t even execute: php composer.phar global require “fxp/composer-asset-plugin:1.0.0-beta3”

So the problem is with composer-asset-plugin?

I had problem upgrading from beta2 to beta3. I fixed it by deleting beta2 completely editing files directly in my home directory. Then I ran composer self-update.

Then I could install beta3 normally.

composer global require "fxp/composer-asset-plugin:1.0.0-beta3"  and it worked.

There is no actually solution because I reinstalled xampp and installed composer and plugin but still cant install yii.

I used xampp’s shell to install composer in htdocs: php -r “readfile(‘https://getcomposer.org/installer’);” | php

and I just won’t install yii. even when I extract advanced yii and I try to update it with composer it so slow- Biggest problem is that I can’t install yii2-user or similar extensions. I guess it is composer’s fault but I don’t know why and how to solve it.

Right now I’m stuck and I can’t work with yii because of composer

I think it’s Composer issue or XAMPP issue. Most likely XAMPP since, as I remember, it was really bad about console.

[size=“2”]If I’m going to guess, its possible an environment variable for php is not set correctly in xammp. S[/size][size=“2”]o you can check to see if you have php set correctly by typing php-v at the command prompt and seeing if you get a response. If that works, continue on and install composer. If it doesn’t, focus on getting that to work. Maybe reinstall xammp if you have to.[/size]

There is a complete set of instructions for installing composer:


There is an installer on that page for windows that will help you get it installed with the environment variable set.

Also some tutorials on setup:



I have not followed the tutorials persoanlly, so not sure if they are 100% correct.

I also use xammp. I just tried downloading the advanced app via composer for a fresh install. The only issue I ran into was that it couldn’t find stability=stable, which I assumed I should use, but when I checked the docs, it said stability=dev. Ran that, worked perfectly. Then I updated composer.json to stability=stable and ran composer update, and that worked perfectly too.

Previously, I have installed:


composer require "fxp/composer-asset-plugin:1.0.*@dev" 


I have run composer self-update since then, but I don’t know if that would make a difference. However since I’m not experiencing any issues, not sure I should mess with it. Please advise if I need to use a different version.

Thank you all, xampp works perfectly everything is already configured as you said. Composer is the problem and there is nothing we can do.

[SOLUTION] I disabled my firewall and antivirus (ZoneAlarm + Avast)