Hi yii people,
is there a reason why yii2-imagine requires Imagine 0.5…* (july 2013) when there is a version 0.6.2 released in November 2014 ?
I’m having problem installing this extension : https://github.com/yii2mod/yii2-image because of versions.
Thanks for your help
yii2-imagine uses incompatible with 0.6.2 version method calls so it should be redeveloped for new imagine version.
As a workaround we use php composer.phar require imagine/imagine “0.6.2 as 0.5.1” (we aren’t using yii2-imagine methods except getImagine which works with 0.6.2 fine) and waiting for yii2-imagine update. Appropriate issue - github.com/yiisoft/yii2/issues/6014
Yes, that is what I assumed. My problem is that my app is already making use of yii2-imagine …so I’m stuck unless I modify yii2-image to not use RGB() (for example).
I have no idea how can this be solved for now. I used 0.6.2 version for using new features like metadata extraction which are not available in 0.5 branch, so we can’t rollback dependency to the old one.
No problem, I’ll wait an update on yii2-imagine …anyway, I like yii2-image. Good job !