Yii1.1 runtime folder error

Hello i cloned an existing yii1.1 project for work. I work on ubuntu. After setup the apache2 configuration the framework return the runtime folder error about the permissions, i tryied to gave 777 -R to the folder but when i do this the website crash and say you can’t reach it. I tried with docker but is the same. Someone can help me?

The assets and runtime folders need to be writable.
You can normally empty them.

But there may be other problems. Check the php log.
And possibly the now fresh yii log in the runtime folder.

Which log? i check the apache error.log and it’s like this

there is a log inside the yii project?

IIRC you can enable the php log in php.ini.

Enable yii debug mode in index.php.

You may not have original content in index.php
This is the default:

// remove the following line when in production mode
defined('YII_DEBUG') or define('YII_DEBUG',true);
// include Yii bootstrap file
// create application instance and run

I use to see the php errors on screen or at least in the apache error log.
The php -v will show info regarding the command line version of php.

Please use preformatted text in the editor when you enter code and error messages.

i did and try to comment something, the app crash calling Yii::createWebApplication($config)->run();



but when i use require_once($yii); no problem

So one file in the framework code is not a problem.

I assume you already consulted the guide

Yes debug mode is active but still no errors, it just display site can’t be reach

Check the that the Yii requirements are fulfilled.
In the web browser enter:


The yii version may be too old. Latest are 1.1.29.

You can try it by just adding it to a new directory and changing one path in index.php (yii)

I no luck, you have to tell us more, at least about your apps directory structure and config (protected/config/main.php).

I ended up using xampp, and it’s working giving permissions to the htdocs. Thanks