[yii\web\HttpException:404]


(babinm89) #1

I’m trying to do Git - Account Setup and Configuration for my project. Bu the installation is throwing the below errors.

Please assist.

vendor\yiisoft\yii2\base\Module.php:461 :- 'Unable to resolve the request "

Error Log:

[yii\web\HttpException:404] exception ‘yii\base\InvalidRouteException’ with message ‘Unable to resolve the request “”.’ in D:\xampp\htdocs\vendor\yiisoft\yii2\base\Module.php:461

Stack trace:

#0 D:\xampp\htdocs\vendor\yiisoft\yii2\web\Application.php(84): yii\base\Module->runAction(’’, Array)

#1 D:\xampp\htdocs\vendor\yiisoft\yii2\base\Application.php(375): yii\web\Application->handleRequest(Object(yii\web\Request))

#2 D:\xampp\htdocs\frontent\web\index.php(18): yii\base\Application->run()

#3 {main}

Next exception ‘yii\web\NotFoundHttpException’ with message ‘Page not found.’ in D:\xampp\htdocs\vendor\yiisoft\yii2\web\Application.php:96

Stack trace:

#0 D:\xampp\htdocs\vendor\yiisoft\yii2\base\Application.php(375): yii\web\Application->handleRequest(Object(yii\web\Request))

#1 D:\xampp\htdocs\frontent\web\index.php(18): yii\base\Application->run()

#2 {main}

2019-03-10 12:27:45 [::1][-][-][info][application] $_COOKIE = [

'PHPSESSID' => 'p6r1phahtel1irvohtq8e6jtf3'

]

$_SERVER = [

'MIBDIRS' => 'D:/xampp/php/extras/mibs'

'MYSQL_HOME' => '\\xampp\\mysql\\bin'

'OPENSSL_CONF' => 'D:/xampp/apache/bin/openssl.cnf'

'PHP_PEAR_SYSCONF_DIR' => '\\xampp\\php'

'PHPRC' => '\\xampp\\php'

'TMP' => '\\xampp\\tmp'

'HTTP_HOST' => 'localhost'

'HTTP_CONNECTION' => 'keep-alive'

'HTTP_UPGRADE_INSECURE_REQUESTS' => '1'

'HTTP_USER_AGENT' => 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36'

'HTTP_ACCEPT' => 'text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8'

'HTTP_REFERER' => 'http://localhost/frontent/'

'HTTP_ACCEPT_ENCODING' => 'gzip, deflate, br'

'HTTP_ACCEPT_LANGUAGE' => 'en-US,en;q=0.9'

'HTTP_COOKIE' => 'PHPSESSID=p6r1phahtel1irvohtq8e6jtf3'

'PATH' => 'C:\\Program Files (x86)\\Common Files\\Oracle\\Java\\javapath;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\System32\\Wbem;C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\xampp\\php;C:\\ProgramData\\ComposerSetup\\bin;C:\\Program Files\\nodejs\\;C:\\Program Files\\PuTTY\\;C:\\Program Files\\Git\\cmd;C:\\Users\\admin\\AppData\\Roaming\\Composer\\vendor\\bin;C:\\Users\\admin\\AppData\\Roaming\\npm'

'SystemRoot' => 'C:\\Windows'

'COMSPEC' => 'C:\\Windows\\system32\\cmd.exe'

'PATHEXT' => '.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC'

'WINDIR' => 'C:\\Windows'

'SERVER_SIGNATURE' => '<address>Apache/2.4.33 (Win32) OpenSSL/1.0.2o PHP/5.6.36 Server at localhost Port 80</address>

'SERVER_SOFTWARE' => 'Apache/2.4.33 (Win32) OpenSSL/1.0.2o PHP/5.6.36'

'SERVER_NAME' => 'localhost'

'SERVER_ADDR' => '::1'

'SERVER_PORT' => '80'

'REMOTE_ADDR' => '::1'

'DOCUMENT_ROOT' => 'D:/xampp/htdocs'

'REQUEST_SCHEME' => 'http'

'CONTEXT_PREFIX' => ''

'CONTEXT_DOCUMENT_ROOT' => 'D:/xampp/htdocs'

'SERVER_ADMIN' => 'postmaster@localhost'

'SCRIPT_FILENAME' => 'D:/xampp/htdocs/frontent/web/index.php'

'REMOTE_PORT' => '53674'

'GATEWAY_INTERFACE' => 'CGI/1.1'

'SERVER_PROTOCOL' => 'HTTP/1.1'

'REQUEST_METHOD' => 'GET'

'QUERY_STRING' => ''

'REQUEST_URI' => '/frontent/web/'

'SCRIPT_NAME' => '/frontent/web/index.php'

'PHP_SELF' => '/frontent/web/index.php'

'REQUEST_TIME_FLOAT' => 1552217265.389

'REQUEST_TIME' => 1552217265

]


(Mehdi Achour) #2

Hi, how did you create your project?


(Alirz23) #3

perhaps your url routes not setup properly


(babinm89) #4

I’m trying to set-up in Windows 10. Could this be a pblm? Will Yii 2 framework works only in Linux?


(babinm89) #5

I checked the application url’s couldn’t trace anything. Anything in specific that I can check?


(tri - Tommy Riboe) #6

Do you have the basic template ‘up and running’?