Yii Performance - I Must Be Missing Something!

Hello, Just started with YII (from an IBM Lotus Domino web background - don’t hold that against me!!!) and was wondering why it takes so long (3-4sec) for a page in the demo app to refresh - I must be missing something!!!

I have two environments one is IIS based and the other is XAMPP -> using kernel cache for IIS and APC for XAMPP, obviously once the cache kicks in performance is brilliant but on first load it’s really terrible in both environments.

Writing a webapp using PHP/JQuery without YII the pages load instantly…any ideas or is this just part of the overhead of utilising a framework?

Using firebug in the demo app I get a page profile (11.67ms, 640 calls) - that’s all good but it takes 3-4seconds to get there. It’s as though the router is having issues parsing the request.

Forgive me if I am a complete spazz and have missed something obvious, I’ve read a few books on YII and scoured the forums so am now in the ‘play’ stage but can’t seem to find a solution. YII is an amazing framework and I really don’t want to give up any time soon as I have a whole lot of work ahead of me and I need the pages to perform.

Thanks heaps in advance!!!!

Are you talking about the demo app that ships with the framework? It should be lightning quick even on a xampp installation. I find the first load is sometimes slow if the asset manager has to push a bunch of assets - but the demo app doesn’t have many assets to publish.

The first thing I’d check to that the asset manager isn’t set to forceCopy.




Thanks Matt for your response, we’re running with the demo app that is supplied with the framework - so it really should be lightning fast, $forceCopy is set to null. Every page refresh or menu link selected has a 3sec delay before a response from the server is received. This is consistent with both IIS(PHP via CGI) and vanilla XAMPP.

public function publish($path,$hashByName=false,$level=-1,$forceCopy=null)



Well I’ve tried everything in a Linux environment and BINGO it works a treat, super fast and brilliant, just like it says on the box. However when running in a windows environment whether it be on server 2008R2 using XAMPP or IIS or even changing OS to windows 7 it runs like a two legged dog adding a 3 second overhead to each response. I’ve played with all different network configurations but it must have something to do with the PHP config (yes I’m using the VC9 NTS Fast CGI version in IIS). Damn it Windows can be a pain in the arse but I have to use it because the business I work for only want to run microsoft products…at this rate I would be happy to run a hidden Linux VM on the Server 2008 host - how desperate is that!!! There must be someone out there who has experienced this issue…someone, anyone, throw me a bone.



For those who are interested, the solution is to disable remote xdebug.

Just comment out the xdebug.remote_<option> entries in the php.ini file and BINGO!!!!