Yii Nginx Configuration

Hello all,

I have this nginx configuration running on my computer (according to the documentation):

server {

    set $host_path "/www/WebCredit";

    access_log  /www/WebCredit/log/access.log;

    server_name  credit.dev;

    root   $host_path;

    set $yii_bootstrap "index.php";

    charset utf-8;

    location / {

        index  index.html $yii_bootstrap;

        try_files $uri $uri/ /$yii_bootstrap?$args;


    location ~ ^/(protected|framework|themes/\w+/views) {

        deny  all;


    #avoid processing of calls to unexisting static files by yii

    location ~ \.(js|css|png|jpg|gif|swf|ico|pdf|mov|fla|zip|rar)$ {

        try_files $uri =404;


    # pass the PHP scripts to FastCGI server listening on


    location ~ \.php {

        fastcgi_split_path_info  ^(.+\.php)(.*)$;

        #let yii catch the calls to unexising PHP files

        set $fsn /$yii_bootstrap;

        if (-f $document_root$fastcgi_script_name){

            set $fsn $fastcgi_script_name;



        include /etc/nginx/fastcgi_params;

        fastcgi_param  SCRIPT_FILENAME  $document_root$fsn;

        #PATH_INFO and PATH_TRANSLATED can be omitted, but RFC 3875 specifies them for CGI

        fastcgi_param  PATH_INFO        $fastcgi_path_info;

        fastcgi_param  PATH_TRANSLATED  $document_root$fsn;


    location ~ /\.ht {

        deny  all;



but when i try to access like this url: http://credit.dev/index.php?r=gii (gii already enabled)

or anything, it show nothing but blank page (in firefox but in Chrome is displaying 500 error).

Is there something wrong with the configuration? please help.