Yii Naming Convention

In the model is a getter function called "getCompleteName". Why must it be called "completeName" in the view, instead of "getCompleteName"?

The same goes for controller names, action names, even table names, etc. that need to be called differently at different times.

Afaik you can use $model->getCompleteName(). It’s the same than $model->completeName.

Ps notice the parens in the first but not in the second. Furthermore, the first syntax allows to pass parameters while the second doesn’t.