Yii 2.0 error in debug

Getting the following error at the bottom of the page:

Not Found (#404): Unable to find debug data tagged with ‘54d81bc085402’.

Not sure why but have tried clearing the cache (both browser and Yii runtime) but still occurs. Did a google search and this did seem to happen in the pre release version of Yii 2.0 but haven’t found any recent issues.

Any other ideas I can try to solve this?



What version of framework are you using?

Sorry for the late reply. It is version 2.0.2

That’s weird. Anything suspicious in logs?

Again, sorry for late reply.

Nothing in the error logs. I am looking in:


Well, there’s no way we can reproduce it w/o any hints.

How does the data get tagged with: ‘54d81bc085402’

Can you point me in the direction of the code I can single step through? I can help with debugging on my end if you can point me in the direction of the code I should be debugging.


Woohoo!!! Solved!!!

Ok, for information, the permissions on the runtime/debug directory did not allow apache/php to create the files it needed. Once I changed the permissions (I changed them to 777 which is ok for the development machine but I set more restrictive permissions on the production machine) it all started working again.

Thanks for your help Sam.


1 Like