Yii Framework Forum

Y.I.I.14 compatibility


(laruniq) #1

Is yii 1.1.14 compatible with PHP 5.6 or PHP 7.X.X ?


(phena109) #2

not quite likely with 7.x but very high possibility with 5.6

the thing is, why not upgrade to the latest version of 1.1.20? that works fine on 7.2. i am using that with 7.2 for almost a year and have no issue at all.

the easiest way to be compatible (other than the user code) is to upgrade to yii 1.1.20. upgrade from yii 1.1.14 should be pretty easy


(laruniq) #3

If i upgrade to 1.1.20 will it break my actual code ?


(phena109) #4

What breaks your code is not likely to be yii. It should be PHP. Upgrade to 1.1.20 is risk free because you can go back to older version by just replace a folder of files.

I recommend you at least try to load your application as a project in PHPStorm (free trial for 30 days) and use it’s PHP compatibility tool to check how much work your need to do to make it PHP 7.2 or 5.6. Of course, to play safe, you want to also make sure your code is under source control.


(laruniq) #5

Thanks :slight_smile:


(laruniq) #6

I have a queston : do you know what this line of code do ?

‘params’=>array(
‘apiUrl’=>YII_DEBUG ? ‘http://debianklerthis:8066’ : ‘http://fondation-zeitgeist.com/pages-oubliee/’,


(Alexander Makarov) #7

1.1.20 is compatible with PHP 7.


(phena109) #8

local dev server and live server i suppose.

If you have another question can you start a new thread? more people can see you questions and help