WSDL extension problem???

Hi guys i want to use WSDL2php extrension of yii to use SOAP functionality

i have Yii1.1.6, php5.0

i have extracted this extension in protected/extension/giix-core/

Now in gii code generator i m getting option ’ wsdl2phpgenerator ’

on clicking on this link i m getting error in morzilla:::

[html]Alias "application.gii.wsdl2php.Wsdl2PhpCode" is invalid. Make sure it points to an existing PHP file.[/html]

plz help me ASAP




You have to place the folder ‘wsdl2php’ into /protected/gii/ as I wrote in the documentation.

The error message tells you, that Yii is missing ‘application.gii.wsdl2php.Wsdl2PhpCode’.

That means Yii is missing the file ‘protected/gii/wsdl2php/Wsdl2PhpCode.php’.

I am newbie in yii, but I believed that extensions to gii should be configured in the main.php as :




            'generatorPaths'=>array('<the path to the gii ext>'),),

I could not make wsdl2php working yet.

So, can you explain in details the install process?

Many thanks

The default generatorPath is set to ‘application.gii’ that means ‘protected/gii’.

See generatorPath

So ‘wsdl2php’ will be found in ‘protected/gii’ if you have no generatorPaths set.

But if you set the generatorPaths in main.php (for other gii modules) you should add ‘application.gii’ too.

I didn’t want to leave another comment as I guess now I just need support…I have not been able to get this to work yet either and I’ve followed the instructions. I have giix installed without issue now and I have application.gii in gen paths, but still no sign of wsdl2php.

I’ve tried it together with giix and it works.

see config/main.php below and screenshots



		// uncomment the following to enable the Gii tool




        'generatorPaths' => array(

                'ext.giix-core', // giix generators





Hi there,

I’ve exactly the same configuration for gii as above but I can’t get the wsdl2php link to be displayed in the gii index page. I’m running yii latest version.

oh i want this to work so bad, since I symlink yii I even went back and did it with yii version 1.1.6 to see if it somehow got disabled in newer versions. And of course tried it after installing giix and setting both application directories…I’m running out of ideas here.

Could it be incompatible with php 5.3? I don’t know where to start to trouble shoot this…if there was an error I could handle it, with it just not showing up and no php_error.log or any other sign that it is malfunctioning I don’t know what to do.

Just an fyi I started a fresh web app on another server that has php 5.2 with nothing else touched and still nothing shows up on gii page.

I use it with php 5.3. but on Windows.

I took a look at the source of the method findGenerators() in framework/gii/GiiModule.php.

Found the row $className=ucfirst($name).‘Generator’; where $name is the directory.

So, Yii searches for wsdl2php/Wsdl2phpGenerator.php, but the filename is Wsdl2PhpGenerator.php.

If you work on Linux, this is not the same.

So try to rename the files (and the classname inside too)

  • Wsdl2PhpGenerator.php -> Wsdl2phpGenerator.php

  • Wsdl2PhpCode.php -> Wsdl2phpCode.php

Please let me know, if it helps.

Hi Joblo,

thank you.

I’ve just had to change:

Wsdl2PhpGenerator.php -> Wsdl2phpGenerator.php

and voila.

Ok, I will update the extension