User Login works in PHP 5.1.6 not in PHP 5.3.3

Told the customer we’d be in production today 5/29 stayed up all night dump the DB from test to production.

Migrated the code and should work but low and behold can’t even login.

Connection to DB is fine, I see products to shop for but can’t add any to the cart in the session state.

Cent OS PHP 5.1.6 everything works. Login not working in in PROD and noticed PHP is at 5.3.3

Using Yii User Extension and Rights Extension for roles. If I type in a username and/or password that doesn’t exist I get the standard error msg.

If I use a good username/pswrd It just redirects to the login page. Nothing in the application.log and httpd logs.

Any ideas?? HELP!

Forgot to mention I ran Yii requirements and everything passed.

Try to use register and captcha fails every time… I gave the app directory and sub all 755 permissions.

Still no luck.

Just an idea… Try to see if cookies are working…

That is session permission error, find your currently session save path in /etc/php.ini

session.save_path =

set that path to 0777 or change the owner .

On centos comand is

sudo chmod 0777 -R YOUR_PATH_HIRE

Or if your php.ini is located somewhere else , type phpinfo(); to see where is located and there you can also se session path