UrlManager not working

Hi there,

Anyone here has successfully using yii2-cms-writedown with working urlManager?

I have the problem when using urlManagerFront (https://github.com/rinodung/yii2-cms-writedown/blob/master/frontend/config/main.php#L52), the page stays at homepage (’/site/index’) instead going to ‘/post/view/’ page. This only happen if urlManager actived.

Here my additional configuration in main.php line;

'urlManagerFront' => [

            'enablePrettyUrl' => true, 

            'class' => 'yii\web\urlManager',

            'showScriptName' => false, 

            'enableStrictParsing' => true,

            'rules' => [

                'post/<post_slug:[\w+\d+\_\-]{1,}>' => '/post/view',

                'defaultRoute' => '/site/index',



//Output url is working (http://localhost/cms/public/post/some-slug-title)

See configuration url here https://github.com/rinodung/yii2-cms-writedown/blob/master/common/models/Post.php#L225

But, I changed the ‘id’ parameter to ‘post_slug’.

And here you can see the post controller setup at https://github.com/rinodung/yii2-cms-writedown/blob/master/frontend/controllers/PostController.php#L86

My .htaccess in ‘/public’ folder is standard

Options +FollowSymLinks

IndexIgnore */*

RewriteEngine on

# if a directory or a file exists, use it directly

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

# otherwise forward it to index.php

RewriteRule . index.php

I don’t know what’s wrong with those codes.

Thank you

[color="#006400"]/* Moved from "General Discussions" to "Extensions" */[/color]

Solve the problem with original sources extension at https://github.com/writesdown/app-cms

Thank you Mr. Agiel.