]URL-rules under Nginx/LINUX don't route,at all

Hi guys, following url-rules won’t route under Nginx on a linux webserver, even though it works quite fine under XAMPP.

If I put

'enablePrettyUrl' => false

,everything works quite fine. So, it’s not a controller or case-sensitive problem,isn’t it? Any ideas,how to fix this problem?

'urlManager' => [

                'class' => 'yii\web\UrlManager',

                'enablePrettyUrl' => true,

                'showScriptName' => true,

                'enableStrictParsing' => false,

                'rules' => [

                    '/' => 'site/login',


                    'reset' => 'site/request-password-reset',

                    'about' => 'site/about',

                    'contact' => 'site/contact',

                    'logout' => 'site/logout',

                    'signup' => 'site/signup',

                    'gii' => '/gii',

                    'debugger' => '/debug',

                    '<controller:\w+>/<id:\d+>' => '<controller>/view',

                    '<controller:\w+>/<id:\d+>' => '<controller>/save-as-new',

                    '<controller:\w+>/<action:\w+>/<id:\d+>' => '<controller>/<action>',

                    '<action:(contact|captcha)>' => 'site/<action>',



Every folder and every file in my webserver have been written lowercased

Is rewrite enabled on the Nginx web server.

No. Since I defined a rewrite roule in Nginx,everything worked pretty well.

Thx a lot for your help. How to remark this thread succesfully solved?

Only way I know of would be to edit the original post and add [SOLVED] to the title. It would be nice if there was a button way. You can give a +1 for the answer :)