Uppercase problem on Linux VPS

Hi guys,

I made a small bog in Yii framework and trying to launch it first time but facing a lot of problem first is all my project folder should be in lower case letters if run on Linux and also in the PostController if try to call


I get error like Post.PHP file doesnt found but if I change above line to this then no error


As I have to make all codes in lowercase to make it run otherwise getting error like Post.PHP doesn’t found.

Any idea how to solve this problem.

Please help in this matter as very disappointed to see this error.

Thanks in advance.


Seems that you have source files with all lower letters… why don’t you rename the source file “post.php” to “Post.php”

That is what happen developing on a machine with case-insensitive file system and then uploading on a case-sensitive machine.

You have to pay attention in respect a standard for the case.

On my point of view, the best solution is to use a case-sensitive filesystem on the developing machine.

Thanks guys for your prompt attention and reply to this thread about mdomba question to "post.php to "Post.php", it was like this but on Linux machine has to be all in lower letters.

anyway meanwhile I found some thing else after making those in lower letters is…

CDbConnection failed to open the DB connection: could not find driver

then I run the yii/requirements and found these extension missing/Failed and the rest Passed, as I was launching my blog site on fresh VPS and did install Mysql,PHP /prepared my VPS machine through some one else.

       - DOM extension 

       - PDO MySQL extension

       - PDO PostgreSQL extension 

       - Memcache extension    

       - APC extension 

       - Mcrypt extension 

       - SOAP extension 

       - GD extension  

Any idea how to install those extension to make my blog run properly?

Thanks again for you guys reply,


These are PHP extension that come with PHP and to enable them you just need to uncoment them in php.ini

Once again mdomba thanks for your prompt attention and guidance, I did follow your instruction and got all problems solved.


Glad you solved it…