Updating A File Referenced In An Assetbundle

I put an asset in an AssetBundle, and a copy is showing up under web/assets as expected. I see that if I edit the original asset that is being called, the file under web/assets is not updated automatically. I deleted the folders under web/assets to get them to regenerate. Is there a better way to get my updated file in there? Thanks.

I am experiencing a similar issue. However, clearing the web/assets folder is not enough. I have to remove the file, reload the page (to get a 404 error on the particular file), save the newly updated file and reload again, before I see any new changes.

I have read the documentation but don’t understand what I should be doing. Does Yii expect us to compile/minify the assets?

Note: My environment is a Debian virtual machine running PHP 5.5.10 and Yii2 is dev.

Virtualbox and nginx?

Anyway try disabling sendfile. More info: http://wiki.nginx.org/Pitfalls#Config_Changes_Not_Reflected

Thanks Renka, that was it.

Sorry dalan, I didn’t mean to hijack your thread. Are you also running your site in a virtual machine?

You can configure asset manager to use symbolic links. I use this feature of Yii2 in my production environment. Assets will always be up to date with source files if you set this and its a bit faster in performance as well - because it does not physically copy the files to the assets location, but just symbolically links them.

You need to enable this by setting the following in your Yii config:

    // ...

    'components' => [

        'assetManager' => [

            'linkAssets' => true,



NOTE: Your hosting environment & OS must support symbolic linking for this to work.