Updated Xampp Windows => Now Serveral Problems

Hi Guys,

I messed up my installation…

Maybe some of you can help me?

Used Yii 1.1.14 for testing.

(Nothing very important, just learning Yii)

Everything was running fine but I was using a pretty old xampp installation.

Somehow this morning I got the (bad) idea "hey, lets update xampp" …

So I did the following:

  • backup my htdocs

  • made backup of mysql databases

  • removed old xampp install

  • installed new xampp from apachefriends.org installer including:

Apache 2.4.4, MySQL 5.6.11, PHP 5.5.3, phpMyAdmin 4.0.4)

  • Restored my backups.

Database works - so far so good.

Now I fired up my yii-test application and got as response:

Then I thought maybe it is a good idea to create a fresh yii-app and track-down what happens wrong.

Fresh App seems to work.

Now I copied in a very simple stand alone test-module I wrote for understanding how things work.

Imported the module in main.php config.


  'myTestModule' => array()


And surfed to the module index.php …

The index.php of the module contains several module-internal links.

I create the links inside the index.php like this:



    <li><? echo CHtml::link('Event Form', Yii::app()->createUrl('myTestModule/event/create')); ?></li>

    <li><? echo CHtml::link('Manage Events', Yii::app()->createUrl('myTestModule/event/admin')); ?></li>


… but instead of the links im getting now:

… so everything after "Yii::app()->" is printed out as normal text.

(In the "main application" it works without problems…)

Next thing:

When I go directly to, for example, "localhost/yii_test/index.php?r=myTestModule/event/admin

I’m getting as output:

In line 14 of EventController is only:

    public function actionAdmin(){

  		$model=new Event('search');









Can someone help me to fix this problem?

Or do I have to do a rollbag to the old installation?

(have a second machine here with old installation … the whole thing is working fine there)

Is it possible that something is now wrong in my php.ini?

And this is just a small little setting that I have to make?

Any help very appreciated.


For other people facing this problems:

In php.ini I had to enable:


Now everything is working like before.