Unable To Use Yiic Shell Command

I am having difficulty using the yiic shell command. I currently have yii framework and requirement folder placed in another folder called yii outside of webroot folder. When I have empty webroot folder and I run yiic (tried: yiic, php /PATH/yiic and php /PATH/yiic.php), I get warning for not having an index.php. When I have generated webroot folder content (using webapp keyword), I get a dump of HTML file.

Here is the link to the paste: fpaste.org/fgN8/

I am currently using XAMPP on Mac OS with several virtual hosts (for different domain names), and this domain name is not localhost (it is in fact, idu.local.host). Not sure if that could be the cause

Paste the error messages here please. That paste is totally unreadable.

Sorry about that, I tried posting it to here jsbin.com/ebocis/1/, where you can see the output. Initially, I thought this is the result of me setting debug to true. But after commenting out the debug line and the call stack line, I still get the same output.

Oh, you need to put this in console.php (AFAIK) and/or index.php:


Thanks, issue solved.