Unable To Create A New Webapp In Yii 2.0

Hi All,

I was bit curious to see the new features in Yii 2.0

Unfortunately ended up frustrated.

Downloaded the yii2.0 build from git and tried to create and see a webapp on my own.

I couldn’t move even a single step ahead to create a new app :(

Methods I Tried out are as below

  1. Old way:

yiic webapp mywebsite


and then I searched for the word ‘yiic’ under root of ‘yii-master’ => no results <Negative>

  1. Searched on the internet (Yii Forum, Git Forum)

and then found this comment from Mr.Qiang Xue


  1. Tried browsing into the Demo App folder which contains (advanced, basic, benchmark)

benchmark-> showing an error and other 2 are just showing the folder view <Negative>

  1. Tried this command :

php yiic.php app/create /var/www/yii2

Still <Negative>

Please Help me to overcome this issue… I think I am missing some major point!

Appreciate a your prompt reply…!

First download framework.

unzip it to your local.

cd <framework path>


Yiic webapp ../testwebapp/

Special Note:

if you are using W8. w8 will not let yiic.bat to work. change its permissions. and allow everything…

i prefer to install Ubuntu or any other distros to work on php… its better easier simpler and faster :P

Hi HSarman,

Please read my Post carefully it says "Unable To Create A New Webapp In Yii 2.0"

=> I know how to work with Yii 1.1 and other versions…

but in Yii 2.0 below command is not working!!

Yiic webapp ../testwebapp/

Thank you.