TreeView not working from cookbook

I am new to Yii.

I have tried the things mentioned here in cookbook

but not worked for me…

I have edited the SQL Query, which working fine.

All the Jquery library is loaded correctly.

<div class="container">

<div class="span-19">

<div id="content">


<ul id="yw0">


</div><!-- content -->


But nothing has been loaded from database.

please help.

How yii determines the first child from table?

Welcome to the forum.

Check with firebug if the action is working correctly.

checked it with firebug, found out 403

after that updated the accessRules in controller

Yii is great… i have implemented the similar functionality using YUI, JSON, PHP…

Yii widget made it very simpler… boost the development time…

Glad it helped you.

P.S: welcome to the forum!

Hi, I am having the same problem that have3fun was having. The html only shows <ul class="threeview-famfamfam" id="yw0"></ul> and no content is loaded. I am using the wiki example. Can you help, is there a problem with accessrules.


There may well be a problem with your access rules, but if you don’t post them then we can’t help.