The "dataProvider" property cannot be empty. <<< what does this mean?

i’m clueless would somebody explain to me?.

You obviously try to use CGridView or CListView. See the API for examples on how to use these classes.

so if i really was tring to use CListView [of which is what i think i’m using] then what should i do? it’s in one of my classes/models

When I ran into this error message a couple of days ago myself, the problem was exactly matching the error output: my dataProvider variable was empty.

Originally, I wrote: ‘dataProvider’=>$dataProvider’, while I should have written ‘dataProvider=>$model->search()’, since otherwise, I would have had an empty variable. Try to check if you have filled your dataProvider variable with any data.



thanks!.. well…the error just disappeared all of a sudden…lol i didn’t know how and why. :P but anyway thanks… at least i know just in case the error pops up again.

oh yeah btw… you were saying that you wrote ‘dataProvider=>$model->search()’, what were you trying to do here? search the site? :D i’m looking for a way to put a search site on my webapp

In fact it was part of my CGridView - when I tried just the dataProvider, it was empty, because I didn’t initialize it in the correspondent model file, while $model was.

You can check something like I mentioned in the blog demo which is included in the yii package.

But good to hear that your problem is solved by Murphy anyway ;)

yeah… thanks :D

:) :)