Stuck installing yii-user-management

Hi guys, this is my odyssey. -.-’

  • installed a new debian server and all packages

  • downloaded and unzipped yii-1.1.10.r3566.tar.gz

  • created a new Web application

  • changed the Database Connection

  • created a new database

  • downloaded yii-user-management_0.8rc6.tar.gz2

  • put the user folder into /protected/modules/

  • and then tried to run the User Management Installer in my Web-Browser

And this is where my problem starts. When I do this


all I get is the normal "Welcome to My Web Application"-Screen, no Installer.

when I do this


I always get this CException - Alias "user.UserModule" is invalid. Make sure it points to an existing PHP file.


306         if($isClass && (class_exists($className,false) || interface_exists($className,false)))

307             return self::$_imports[$alias]=$className;


309         if(($path=self::getPathOfAlias($alias))!==false)

310         {

311             if($isClass)

312             {

313                 if($forceInclude)

314                 {

315                     if(is_file($path.'.php'))

316                         require($path.'.php');

317                     else

318                         throw new CException(Yii::t('yii','Alias "{alias}" is invalid. Make sure it points to an existing PHP file.',array('{alias}'=>$alias)));

319                     self::$_imports[$alias]=$className;

320                 }

321                 else

322                     self::$classMap[$className]=$path.'.php';

323                 return $className;

324             }

325             else  // a directory

326             {

327                 if(self::$_includePaths===null)

328                 {

329                     self::$_includePaths=array_unique(explode(PATH_SEPARATOR,get_include_path()));

330                     if(($pos=array_search('.',self::$_includePaths,true))!==false)

Stack Trace


+  /www/htdocs/test75490/framework/YiiBase.php(198): YiiBase::import("user.UserModule", true)


+  /www/htdocs/test75490/framework/base/CModule.php(283): YiiBase::createComponent("user.UserModule", "user", null, array("debug" => true))


+  /www/htdocs/test75490/framework/web/CWebApplication.php(331): CModule->getModule("user")


+  /www/htdocs/test75490/framework/web/CWebApplication.php(270): CWebApplication->createController("user/install")


+  /www/htdocs/test75490/framework/web/CWebApplication.php(135): CWebApplication->runController("user/install")


+  /www/htdocs/test75490/framework/base/CApplication.php(162): CWebApplication->processRequest()


+  /www/htdocs/test75490/framework/testdrive/index.php(13): CApplication->run()

I tried this not only on this debian server, I also tried it on ubuntu, MAMP and on some webspace…

I also tried changing privileges of every (and I mean every) File and Folder to 777 (bad practice, I know), but still nothing.

I have absolutely no idea what else I could do to make YUM work. :confused:

I would really appreciate any advice. :)

Boy, I am so stupid. Nevermind.

So when I extract yii-user-management_0.8rc6.tar.bz2 I get a user folder and only the content of this folder goes into modules. :D