SQLITE database for yii2 project - cant open file - root directory

I am using a Windows 11 work environment with the latest PHP Storm installation and the latest stable release of Yii2. I installed the “basic” template and I am attempting to use a SQLITE database for my connection, not MySQL. When I load the gii module and attempt to access the Model generator I continually get this error:

Database Exception – yii\db\Exception

SQLSTATE[HY000] [14] unable to open database file

Error Info: Array ( [0] => HY000 [1] => 14 [2] => unable to open database file

Could this be a permissions issue on Windows? I have tinkered with different ways to name the database file. I can actually open up a raw PHP connection to the file and read and write to it from within PHPStorm. Here is the code:


define('SCRAPE_DATABASE', "webscrapes" . date('ymd') . ".sqlite");

return [
    'class' => 'yii\db\Connection',
    'dsn' => 'sqlite:/web/' . SCRAPE_DATABASE,

I think this is all the relevant info I have. Can’t figure this out.
The topic says root directory but in the code sample I tried putting the file in the web directory

I fixed it.

I think the Yii2 documentation needs to be fixed for Windows users (or maybe for all users?).
The Yii2 documentation references a SQLITE DSN as having this prefix: sqlite:/<path_to_file> but according to the PHP PDO SQLITE reference as well as this article:
SQLite PHP: Establish a Connection to SQLite Database (sqlitetutorial.net)

It appears that using this prefix → sqlite:<path_to_file> (no dashes!) is the accepted form.