[SOLVED] Unable to resolve the request

I see such pages instead of every page of my project:

[indent]Page Not Found

Unable to resolve the request "my/pages".

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

2012-05-07 13:06:03 Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/1.0.1b DAV/2 PHP/5.3.12 with Suhosin-Patch Yii Framework/1.1.10[/indent]

I don’t know what could cause this. I haven’t touched the project for a while, an recently I’ve updated Yii. Maybe PHP or Apache was updated, too, during the time I haven’t edited project — I’m not sure.

The message above is shown when I try to open /my/pages/. Both MyController in controllers/ and actionPages() in it exist, of course. I’ve thought that there is some problem with file permissions (the OS is Arch Linux), so I tried to move the entire project from NTFS partition to ext4 partition, but nothing changed. So, I think the problem is not with file permissions.

The main configuration file is almost default:



return array(


	'name'=>'Well... my project title is here :-)',









			'password'=>'Well... my password is here :-)',










			'caseSensitive' => false,

			'showScriptName' => false,


				'r/<id:\d+>.<mime>' => 'showResource'

				// Tried to remove this. The problem didn't disappear.




			// Well... my MySQL connection data are here :-)


//		'errorHandler'=>array(

//			'errorAction'=>'site/error', // Commented out as far as I've deleted default SiteController.

//		),






					'levels'=>'error, warning',






		'adminEmail'=>'Well.. my email is here :-)',




I tried to comment out almost every line in the config, but nothing changed.

So, I hope somebody can help me. What could it all mean?

What a stupid problem!

As I’ve mentioned, I’ve reinstalled PHP in Arch Linux. I used XAMPP/LAMPP from apachefriends.org before, and now I installed separate Apache, PHP and MySQL. So, I just had another php.ini file but didn’t pay attention that it had short_open_tag = Off by default. That’s why all my files using short open tags (<? instead of <?php) were not parsed as PHP — they were included and outputed as plain text. (But it’s not easy to notice that as far as Yii cleans all previous output before showing error message.)

So, the problem is solved. Maybe this solution will be useful for some novices while it’s not the problem with Yii in fact.