SOLVED: Strange Bug/Error after FTP Upload, Yii shows content of components/Controller.php

Hey there,

i just uploaded my yii-application to my webserver (FTP).

Now when I open the webapplication Yii just shows the content of "/components/Controller.php"

I’ve never experienced that before. There are no errors /etc , just the plain content of the file.

Any ideas?


It seems like your web server lacks PHP support.

Garbled php tag?

I haven’t changed any PHP-settings. And it perfectly worked before.

Also this comes up : 㱢爠⼾਼戾䙡瑡氠敲牯爼⽢㸺†䍬慳猠❃潮瑲潬汥爧潴⁦潵湤⁩渠㱢㸯楳⽨瑤潣猯睰ㄱ㌲㌶㙟㡚䱅䙔䥌㤷⽷睷⽹楩⽰牯瑥捴敤⽣潮瑲潬汥牳⽐牯摵捴䍯湴牯汬敲⹰桰㰯戾渠汩湥‼戾㌼⽢㸼扲 㸊

I have no clue where this stuff comes from? Must be somewhere in the YII-Libraries.

Any ideas?


Upload again or download and compare for differences.


My local copy works perfect, uploaded again and still have the bug :(


If you components/Controller.php was set Unicode (UTF-8, no BOM).

I changed it to just (UTF-8).

On my local Mac-Filesystem it is no problem, but Linux seems to have a problem …