Router for admin module


I have tried to active the url friendly option with success.

Now my module called 'admin' does not work anymore.


Is there a way to disable url friendly per module? I don't even know if it makes sense this question.

Or now do i have to create rules for routes including the admin module so it can be parsed?

Ismael, o esquema de url friendly dispensa o uso do


sua URL deveria ser agora tipo  localhost/seusite/depoimento/admin

o controlador depois a ação, por exemplo, a ação admin do controlador testemunha:


a ação list


assim por diante…

cheers!! :)

Cara, eu vou ter que falar inglês agora senão o bixo pega!

The problem occured was the attribute of 'urlManager' showScriptName => false

If it is true, nothing is recognized. But the url are correcly generated.

See this:

Module admin with showScriptName = true



Module admin with showScriptName = false


Error not found

I cannot understand why.

See in the guide about 'hidding index.php'.

Just setting showScriptName to false will not make it work

Thank you.

I really forgot to do this step. My bad not looking this… i thought it was already done, but was in another site.  :-X

I’ve just created a file “.htaccess” in the main directory with respective apache configuration listed in the guide. And now Works perfecly as expected!!!  ;D