[RESOLVED] Default Application demo/demo admin/adin Login

The issues is that after creating a starting set-up with "yiic webapp demo" for example and trying to login/logout , the "Login" does not change to "Logout (demo)" or "Logout (admin"). Instead, it continues to display "Login" and redirects me to the home page.

This worked before - what could have caused it? I checked runtime/application.log and did not find any errors.

Does not look like Yii problem, but rather environment misconfiguration.

You may want to check:

-> writing permissions for PHP session directory (does the directory exist? - write simple test script storing variable into session and reading it…)

-> enable cookies if using cookie based authentication

If you can run debug, just stop script execution in …/components/UserIdentity::authenticate() and see why you cannot log in… if problem persists, specify: linux/windows? Anything inside …/protected/runtime/application.log …?



Yeah, that is what I’m thinking - PHP configuration issue. I’m running Apache 2.2.18 on Slackware64 13.1. Permissions look good and no errors are found in runtime/application.log.

I’ll look into PHP configuration even though I haven’t changed it since the last time it worked.

It turns out - if I enable Gii and try to log in, it won’t let me either - it just keeps prompting for the Gii password.

All of this was due to the permission issue on the directory to which sessions were supposed to be written.