ReflectionException Class does not found


I have added a new class to site.css file and tried to use it on a form. In css file I have "large-input" to have font-size as 18px.

<?= $form->field($model, ‘name’, [‘class’=>‘large-input’])->textInput([‘maxlength’ => 80,‘placeholder’ => ‘Name’])->label(false) ?>

After this I keep getting "ReflectionException Class large-input does not exist" error. I read couple of discussion threads on Github and Stackoverflow they talk about installing the extensions using composer, adding "access as" to config files.

What I have is an advanced app (installed via composer) no 3rd party extensions.

I also ran php composer.phar require mdmsoft/yii2-admin "*"

I am not a seasoned Yii developer. Yii 1.x was simple enough to add a new class and call it on form and worked like a charm. Probably I am missing something really simple. Without the class reference form is working just fine. Any ideas?

Thank you

You are trying to set css class in the field() method which configures ActiveField object and in this case "class" refers to php class (not css). Set it in the textInput() method.

Awesome, that worked. Embarrassing as I look back to ask such a silly question.