'protected/yiic shell' gives bad error when defaultController is redefined

Small issue, but in the shell when I type 'protected/yiic shell' i get a html type error message which looks ugly and doesnt really tell me whats wrong:


        "-//W3C//DTD XHTML 1.0 Transitional//EN"


<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">


<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>

<title>Page Not Found</title>

<style type="text/css">


body {font-family:"Verdana";font-weight:normal;color:black;background-color:white;}

h1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }

h2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }

h3 {font-family:"Verdana";font-weight:bold;font-size:11pt}

p {font-family:"Verdana";font-weight:normal;color:black;font-size:9pt;margin-top: -5px}

.version {color: gray;font-size:8pt;border-top:1px solid #aaaaaa;}





<h1>Page Not Found</h1>

<h2>Unable to resolve the request &quot;sitee&quot;.</h2>


The requested URL was not found on this server.

If you entered the URL manually please check your spelling and try again.



If you think this is a server error, please contact the webmaster.


<div class="version">

2009-06-22 12:59:49 </div>



This happened because i redefined 'defaultController'=>'site2' in the config/main.php, while testing out things

Could you please create a ticket for this? Thanks!

Of course :) I wasn’t sure if this “qualified” for a bug, but I’ll make one right now.


There is no good solution to this issue. You may consider using the following command

to enter yiic shell, which should avoid such problem:

cd entryScriptPath

protected/yiic shell config/main.php

OK, I encountered another bug, but before posting it in the google bug system, I wanted to ask you about it here first.

I made a BaseController.php in components to handle a "must login" issue. So then SiteController extends this BaseController.

However, when this is the case the shell wont start at all. No error, no shell. Just newline in bash. Would you like me to file this in the bugsystem?

Are you using "protected/yiic shell config/main.php" to start the shell?

Nope, but tried a “protected/yiic shell protected/config/main.php” now and that worked, thanks :) (my config folder is put under protected by “yii webapp” command)