Problems running app on Debian Etch


I’ve an app working fine on Ubuntu server, with php 5.3.2.

I’ve then deployed the very same app on a Debian Etch server, running php 5.2 and mysql 5.0.32, but doesn’t work.

I get an exception saying a database table doesn’t exist, while I double checked via phpmyadmin and cli that exists. I tried issuing the same command "SHOW COLUMNS FROM MARCHE that Yii does, and gets executed.

I ran the Yii requirements check and the relevant items are shown as OK.

What could be the problem?


Can’t say what is the problem… could be the table name case (lower/upper) ?

or a prefix?

sadly not. The two db are identical, table names are all uppercase, and so are in the two versions…

Adding PHP5.3 packages using the repo below [1] finally made the app work as it should.

I guess you should update minimum requirements. Php 5.1 is not enough anymore, I’d say. Or the code executed by Yii DB provider is not compatible with older versions.

The problems arised on this query, which is issued by the model:


I ran this from phpmyadmin, from custom script and from mysql command line, it always ran fine.

When ran by Yii causes exception.