Problems installing with composer

I am trying to install version 2.0.10 for the first time using CCI on Mac

I run this command

[font="Menlo"][size="2"]composer create-project yiisoft/yii2-app-basic basic 2.0.10[/size][/font]

[font="Menlo"][size="2"]Then i get this output[/size][/font]

[color="#34BC26"][font="Menlo"][size="2"]Installing yiisoft/yii2-app-basic (2.0.10)[/size][/font][/color]

[color="#34BC26"][font="Menlo"][size="2"] - Installing yiisoft/yii2-app-basic (2.0.10)[/size][/font][/color]

[color="#34BC26"][font="Menlo"][size="2"] Downloading: 100% [/size][/font][/color]

[color="#34BC26"] [/color]

[color="#34BC26"][font="Menlo"][size="2"]Created project in basic[/size][/font][/color]

[color="#34BC26"][font="Menlo"][size="2"]Loading composer repositories with package information[/size][/font][/color]

[color="#34BC26"][font="Menlo"][size="2"]Updating dependencies (including require-dev)[/size][/font][/color]

[color="#34BC26"][font="Menlo"] [/font][/color]

[font="Menlo"][size="2"]After this i get this error, repeated… and repeated[/size][/font]

[color="#BFBFBF"][font="Menlo"][size="2"]The "" file could not be downloaded: failed to open stream: Operation timed out[/size][/font][/color]

[color="#BFBFBF"][font="Menlo"][size="2"]Retrying with degraded mode, check for more info[/size][/font][/color]


[font="Menlo"][size="2"]Any idear what i am doing wrong?[/size][/font]

You’re doing everything right. The issue is your Internet connection.

I have 200 mbps internet connection (fast cable). is this a firewall issue?

Could be.

Ok. your were correct. MY internet provider confirmed their was a fault with my IPV6 in my router, so they are sending me a new router. I installed an old router (temporarily) and it worked fine.

Thank you.