Problem with npm-asset dependencies

(Cronopios) #1

I am trying to install puppeteer:

composer require npm-asset/puppeteer


  • npm-asset/puppeteer requires npm-asset/extract-zip and npm-asset/debug >=3.1.0

  • npm-asset/extract-zip requires npm-asset/debug 2.6.9

The conclusion is that puppeteer is not installed, because composer can only install one of: npm-asset/debug[2.6.9, 3.1.0].

Is there any way to resolve this?

FWIW, I can run

npm install puppeteer

successfully. I guess NPM can install multiple versions of the same library, while Composer can only have one.

I have Yii, Composer 1.6.5 and npm 5.6.0.

(Cronopios) #2

I worked around this re-enabling temporally the composer asset plugin:

"fxp-asset": {

    "enabled": true,

    "resolutions": {

        "npm-asset/debug": "^3.1"



but I wonder if there is not any way to achieve this using asset-packagistā€¦