Problem With Memcached Windows 64-Bit Build [Solved]

I encountered problems with Memcached. It took me a while to figure out that the cause was in 64-bit build of Memcached that doesn’t accept Unix time as a parameter for expiration.

I found out it has been discussed already:

Yii use the Unix time as a parameter instead of number of seconds starting from the current time.

Unfortunately, although some other Win64 builds accepted the Unix time parameter they had another issues.

Eventually I resorted to x86 build of Memcached which works ok.