Problem with ImportCSV (by Ardem)


I am trying to get ImportCSV to work. I have followed the install requirements.

I have created the folder as below and set the permissions to 777




            'path'=>'upload/importCsv/', // path to folder for saving csv file and file with import params




When i try to import a CSV file i get a:

Not Found

The requested URL /importcsv/default/upload was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

When i take a look in "assets/download.js" there is a line:

action : '/importcsv/default/upload',

When i created this map in my wwwroot i don’t get the 404 error, i can start select a CSV en submit it. But the respons is first “Loading…” and then “aa” and the file isn’t uploaded.

Can anyone help me?


I have tried all kinds of combinations


Also having some problems with getting the extension to work.

At the second step (i.e after the file upload) where I have to choose the delimiter and table, this doesn’t lead to the third step; I see in javascript console that I get an http error 500.

The csv file has been correctly uploaded.

Any help on that ? Thanks

Would anyone be able to reply to "gijs" on post #2725 on 2011/02/01 09:43am regarding finding out what exactly he did make the CSV import module work? (Being new to this forum, I am not allowed to do it–bummer!).

I have his exact problem.

It would be nice if gijs could share what he did to resolve the problem.

I have tried a number of things to no avail.


Hi guys, i have the same problem when i try to implement import csv in my application.

I have followed the instruction but this extension still doesn’t work. After I choose a csv file from the upload form, the “loading” text appears but there’s nothing happened.

Does anyone of you already solve this problem?

I will be very grateful if you could share the solution here.



i also get a script error at the third step i think i have tracked down the issue that i get.

The problem i see is this

when i import a csv that has table looking like this




then it works

if i then





then it does not work i suspect the "" around the columns is the issue

using firebug i get a message saying

" missing ) after argument list"

and is i check with firebug what the javascript call locks like it seems that the javascript needs to have \ to comment out the " in the csv list


<option value=\"1\" >\"SN\"</option><option value=\"2\"

Original looks like this

toThirdStep("<table class=\"importCsvTable\" cellpadding=\"5\" cellspacing=\"1\" border=\"0\" width=\"100%\"><tr><td width=\"50%\">Mode <span class=\"require\"></span></td><td width=\"50%\"><select name=\"Mode\" id=\"Mode\"><option value=\"1\" >Insert all</option><option value=\"2\" >Insert new</option><option value=\"3\" >Insert new and replace old</option></select></td></tr><tr><td width=\"50%\">Items per one request <span class=\"require\"></span></td><td width=\"50%\"><input type=\"text\" name=\"perRequest\" id=\"perRequest\" value=\"10\"/></td></tr><tr><th colspan=\"2\">Keys for compare</th><tr><td>Table pole</td><td><select name=\"Tablekey\"><option value=\"\"></option><option value=\"id\" >id</option><option value=\"customerName\" >customerName</option><option value=\"addedDate\" >addedDate</option></select></td></tr><tr><td>CSV pole</td><td><select name=\"CSVkey\"><option value=\"\"></option><option value=\"1\" >"SN"</option><option value=\"2\" >"Model"</option><option value=\"3\" >"MAC"</option><option value=\"4\" >"WPA"</option><option value=\"5\" >"3DES"</option><option value=\"6\" >"SW"</option></select></td></tr></tr><tr><th>Table pole</th><th>CSV pole</th></tr><tr><td>id</td><td><select name=\"Poles[0]\" id=\"select_0\"><option value=\"\"></option><option value=\"1\" >"SN"</option><option value=\"2\" >"Model"</option><option value=\"3\" >"MAC"</option><option value=\"4\" >"WPA"</option><option value=\"5\" >"3DES"</option><option value=\"6\" >"SW"</option></select></td></tr><tr><td>customerName</td><td><select name=\"Poles[1]\" id=\"select_1\"><option value=\"\"></option><option value=\"1\" >"SN"</option><option value=\"2\" >"Model"</option><option value=\"3\" >"MAC"</option><option value=\"4\" >"WPA"</option><option value=\"5\" >"3DES"</option><option value=\"6\" >"SW"</option></select></td></tr><tr><td>addedDate</td><td><select name=\"Poles[2]\" id=\"select_2\"><option value=\"\"></option><option value=\"1\" >"SN"</option><option value=\"2\" >"Model"</option><option value=\"3\" >"MAC"</option><option value=\"4\" >"WPA"</option><option value=\"5\" >"3DES"</option><option value=\"6\" >"SW"</option></select></td></tr></table><br/><br/><strong><em>Notes</em></strong><br/>&laquo;Insert all&raquo; - All items add. Old items remain unchanged<br/>&laquo;Insert new&raquo; - New items add. Old items remain unchanged<br/>&laquo;Insert new and replace old&raquo; - New items add. Old items replace", ";", "Customer");


Can I ask for help with implementing the extension? I did the instructions but I can’t access it? What is the correct URL for accessing it? I did the path for the csv file. I use this URL “http://localhost/gxi_sales/gxi_sales/index.php/importcsv/default” is this wrong? Please help thanks I am just new with this one so quite confused with the codes. Thanks God Bless! :))