Problem With Dataprovider / Datagrid


I am using this code to pull the data from the DB …

$competency_required_level_data = new CActiveDataProvider(CompetencyRequiredLevel::model()->belongsToJobTitle($job_title_id)->with("job_title.job_role.job_role_competencies"), array("criteria" => array("together" => true, "order" => "job_role_competencies.sort_order")));

In my datagrid I am doing …


	"name" => "",

	"header" => "Order"


The just shows an empty column. I have also tried getting data for the job_role_competencies.

The only one I can get data for job_title.

Is there anyway to fix this?


I didn’t even knew that was possible. Maybe define it as an array of arrays:










Ok will give it a try.

Ok, I have tried it and it still does not work.

Also bit more information, if I misspell a column it gives me the SQL in the error …

CDbCommand failed to execute the SQL statement: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘job_role_competences.sort_order’ in ‘order clause’. The SQL statement executed was: SELECT AS t0_c0, t.fk_id_with_competency_id_field AS t0_c1, t.fk_id_with_job_title_id_field AS t0_c2, t.fk_id_with_competency_level_id_field AS t0_c3, t.deleted AS t0_c4, t.created_date AS t0_c5, t.updated_date AS t0_c6, t.created_user_id AS t0_c7, t.updated_user_id AS t0_c8, AS t1_c0, job_title.fk_id_with_job_role_id_field AS t1_c1, AS t1_c2, job_title.sort_order AS t1_c3, job_title.deleted AS t1_c4, job_title.created_date AS t1_c5, job_title.updated_date AS t1_c6, job_title.created_user_id AS t1_c7, job_title.updated_user_id AS t1_c8, AS t2_c0, job_role.fk_id_with_job_family_id_field AS t2_c1, AS t2_c2, job_role.deleted AS t2_c3, job_role.created_date AS t2_c4, job_role.updated_date AS t2_c5, job_role.created_user_id AS t2_c6, job_role.updated_user_id AS t2_c7, AS t3_c0, job_role_competencies.fk_id_with_competency_id_field AS t3_c1, job_role_competencies.fk_id_with_job_role_id_field AS t3_c2, job_role_competencies.sort_order AS t3_c3, job_role_competencies.deleted AS t3_c4, job_role_competencies.created_date AS t3_c5, job_role_competencies.updated_date AS t3_c6, job_role_competencies.created_user_id AS t3_c7, job_role_competencies.updated_user_id AS t3_c8 FROM CompetencyRequiredLevel t LEFT OUTER JOIN JobTitle job_title ON ( AND (job_title.deleted = ‘no’) LEFT OUTER JOIN JobRole job_role ON ( AND (job_role.deleted = ‘no’) LEFT OUTER JOIN JobRoleCompetency job_role_competencies ON ( AND (job_role_competencies.deleted = ‘no’) WHERE ((t.deleted = ‘no’) AND (fk_id_with_job_title_id_field = ‘61’)) ORDER BY job_role_competences.sort_order LIMIT 10 (/home/lucomdev/yii/framework/db/CDbCommand.php:541)

I have also tried t3_c3 which is suppose to the job_role_competencies.sort_order but still nothing.

Typo !!


Ah, sorry.

You have intentionally made a type here … :P

Well, could I ask you what exactly is the problem?

First, what is this belongsToJobTitle() function that you’ve used? It should return a model finder instance instead of actually perfoming any query to the db, make sure it really does that.

Second, it’s better to put the with() in the the criteria too, try this:

$criteria=new CDbCriteria();

$criteria->with=array('job_title', 'job_title.job_role', 'job_title.job_role.job_role_competencies');



$competency_required_level_data = new CActiveDataProvider(CompetencyRequiredLevel::model()->belongsToJobTitle($job_title_id), array(



Hi everyone,

Thanks for your advice.

In the end I used a CArrayDataProvider and wrote a method to generate the array which gave me more flexibility.