Problem with basic app and symlinks in Windows

I’m trying to contribute to Yii and have been following this page however have encountered a problem I can’t get past.

I have my own existing installation of Yii where I have tested my code but am also trying to set up an environment going by the pages instructions, but when I get to step 3 and run:

php build/build dev/app basic

I get the error that there is no composer.json present, so I created one based off of the composer file within the composer.json found within the basic app on GitHub.

Then I tried again and then got this error:

PHP Warning 'yii\base\ErrorException' with message 'symlink(): Cannot create sym link, error code(1314)'

I have looked around for solutions but the few things I found haven’t helped, such as starting Xampp in Administrator mode.

The above is by running the command in CMD, I have also tried in Git Bash but with that I get the error:

Unknown command "dev\app".

FYI I am on Windows 7 so symlink should be supported.

Any ideas!?

Try running CMD as admin.

Next time, try and Google the error message - Windows is telling you what’s wrong:


Sorry I missed your reply and deleted my post as I didn’t think anyone had seen it.

Yes, I know what the problem was but thought it may have something to do with the Yii repo as I had previously already entered in my Github credentials elsewhere and saved them, but then realized that would have been using https, so I changed this request to using https over from the default ssh since I haven’t setup a key for Github and it worked :)