Problem with 1.1.6


I am currently working on a project which is build using 1.1.5. When 1.1.6 is released, I upgraded by framework. But after this, all pages having Cgridview, ajax is not working. I get the following error in firefox error console,

Error: settings is undefined

Source File: http://localhost/assets/4990c053/gridview/jquery.yiigridview.js

Line: 225

It seems to be some issue with the new selectCheckedRows function.

Please note that to upgrade my framework, I simply point the framework path to the new folder for 1.1.6.

Can anyone suggest if I am missing any steps for upgrading framework?


Now that I come to think of it, the first thing to do is to empty your assets folder, because I think the javascript file has changed, so it will need to be published again. Give that a try and let us know if that works.

Yes, there where some errors in the jquery.yiigridview.js file… sorry for that…

They where solved later and are in the SVN trunk…

Best way to solve this would be to take the current version -…yiigridview.js

And like RedRabbit wrote above… don’t forget to empty the assets folder…

I did cleared the Assests folder. and thanks for the link, using this js, error is gone now.

@Always Smile, is the problem solved after updating yiigridview.js to the current version?

Yes it is solved.