Problem when installing yii2-app-basic

What I did:

  1. Fresh new installation of CentOS 7

  2. Installed:

    • MySQL 5.6.22

    • Apache 2.4.6

    • PHP 5.4.16 (+modules)

    • composer 1.0-dev (4569f528f66739ec0a3be1075e2c01d6062b0b41) 2014-12-22 11:50:02 as /usr/local/bin/composer

    • composer self-update

  3. Related to yii:

    • composer global require "fxp/composer-asset-plugin:1.0.0-beta4" - OK

    • composer create-project --prefer-dist yiisoft/yii2-app-basic basic - MY PROBLEM HERE

When I run the above command, I get the following screen:


Installing yiisoft/yii2-app-basic (2.0.1)

  • Installing yiisoft/yii2-app-basic (2.0.1)

    Loading from cache

Created project in basic

Loading composer repositories with package information

Installing dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

Problem 1

- yiisoft/yii2 2.0.1 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.

- yiisoft/yii2 2.0.0 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.

- Installation request for yiisoft/yii2 * -> satisfiable by yiisoft/yii2[2.0.0, 2.0.1].

Potential causes:

  • A typo in the package name

  • The package is not available in a stable-enough version according to your minimum-stability setting


Please, help me to understand what I am doing wrong or what I missed to do.

Thank you.

Thank you very much moginn!

In my case, the reason for the problem was that I run

[indent]$ composer global require "fxp/composer-asset-plugin:1.0.0-beta4"[/indent]

as a root. My assumption was that ‘global’ flag would install (make available/accessible) the ‘asset’ for all the users on the system, while (it seems) it only installed it for all the projects of the users under which the command is executed.

After I run the

$ composer global require "fxp/composer-asset-plugin:1.0.0-beta4"

from the same user that later on runs the

$ composer create-project --prefer-dist yiisoft/yii2-app-basic basic

everything is fine.

Thank you and best regards!