Prevent password prefill in FF

Not really Yii related, but just in case someone has the same problem: My application has a page to create/update users, and to enter a password. Sadly, firefox now allways prefills the username/password fields with my stored login data. To prevent that, you can use this:

<?php echo CHtml::form('','post',array('autocomplete'=>'off')); ?>

I had the same problem and used the same fix, however for me it was chrome that was to vigorous and decided that my email field on the update form was the same as the username field on the login form.  Never had that problem with CakePHP, not sure why.

Would be interesting, after which rules they decide when to prefill. I first thought it was the name "login", that i used in my model. But even after changing that to "benutzername" (german for 'username'), still the same behaviour. It seems to have to do with the password fields.


the following mozilla page shows how to disable the autocompletion and gives also a few facts about how autocomplete form-fields are recognized:…_Autocompletion