Post Installing Jui Extension For Yii 2

I am trying a lot of ways to do it. My trouble maybe is that I am a noob talking about compose.

I already have my basic project installed through the following command :

php composer.phar create-project --prefer-dist --stability=dev yiisoft/yii2-app-basic basic

But I still can not get a good way to include the JUI extention.

I already tried what says on the :

php composer.phar require --prefer-dist yiisoft/yii2-jui "*"

Without any luck.

I did it by hand, without any luck neither :P. Don’t even ask how I did it by hand … maybe I screw something up.

Anyone knows the correct way to do this ?

Calling it wrongly.

Either run

$ php composer.phar require yiisoft/yii2-jui "*"

or add

"yiisoft/yii2-jui": "*"

to the [font="Courier New"]require[/font] section of your [font="Courier New"]composer.json[/font] file.

…and then run a

php composer.phar update

PS: You may want to do some reading on using composer.

It is exactly what I am soing without luck. This is the error that I have :

./composer.json has been updated

Loading composer repositories with package information

Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

  Problem 1

    - The requested package yiisoft/yii2-jui could not be found in any version, there may be a typo in the package name.

Potential causes:

 - A typo in the package name

 - The package is not available in a stable-enough version according to your minimum-stability setting

   see <> for more details.

Read <> for further common problems.

Installation failed, reverting ./composer.json to its original content.

I tried the --dev option too. Same error.

What’s your minimum stability set to in composer.json?

I have the composer fiel created, but there is no info inside. Was created automatically when the yii project started. Can you share yours please ?

Set it to dev and try:

minimum-stability: dev

With minimum stability to beta it is working now :)

minimum-stability: Beta

I am attaching my composer config file.



Good for you B).