phpunit, codecept commands

I am following instructions in file, which was created automatically when creating advanced demo yii application:


They say " 1. Install Codeception if it’s not yet installed:"

I run: c:\Bitnami\wampstack-5.4.38-0\apache2\htdocs\TamasCovacsYii\advanced>composer global require "codeception/codeception=2.0." "codeception/specify=" "codeception/verify=*"

They say “If you’ve never used Composer for global packages run composer global status.”

I run: c:\Bitnami\wampstack-5.4.38-0\apache2\htdocs\TamasCovacsYii\advanced>composer global status

They say :Then add <directory>/vendor/bin to you PATH environment variable. Now you’re able to use codecept from command line globally."

I found directory with codecept using:

c:\Bitnami\wampstack-5.4.38-0\apache2\htdocs\TamasCovacsYii\advanced>cd c:\

c:\>dir codecep* /s

In my case this outputted directory „C:\Users\Gintare\AppData\Roaming\Composer\vendor\bin“

which i added to System->Advanced System Settings → Environmental variables → PATH

But if i try codecept or bin\codecept command from command line, it is not recognised – the message is „The system cannot find the path specified.“ I have tried the following commands:




The phpunit or bin\phpunit is also not recognised as a command, athough it is on the path


contains codecept and phpunit.

I have checked composer.json file in directory:

C:\Bitnami\wampstack-5.4.38-0\apache2\htdocs\TamasCovacsYii\advanced. It had no phpunit and codeception

"require-dev": {

    "yiisoft/yii2-codeception": "*",

    "yiisoft/yii2-debug": "*",

    "yiisoft/yii2-gii": "*",

    "yiisoft/yii2-faker": "*"


Thus i have added these lines to the file:

"require-dev": {

    "yiisoft/yii2-codeception": "*",

    "yiisoft/yii2-debug": "*",

    "yiisoft/yii2-gii": "*",

    "yiisoft/yii2-faker": "*",



    "codeception/specify": "*",

    "codeception/verify": "*"


and run from command line composer update:

c:\Bitnami\wampstack-5.4.38-0\apache2\htdocs\TamasCovacsYii\advanced>composer update

It loaded and installed dozens of libraries including: "phpunit/phpunit":"4.5.", "codeception/codeception:","codeception/specify": "", "codeception/verify": ""

But command bin\codecept and bin\phpunit is not working from command line:


The system cannot find the path specified.

If I check folder


I see four files, codecept, codecept.bat, phpunit, phpunit.bat

I also have symfony project with analogous composer.json file. If i change cmd to that project folder i can run phpunit:


PHPUnit 4.5.0 by Sebastian Bergmann and contributors…

About phpunit see:

About codeception see:

Why codecept and phpunit is not working from yii project folder? Where is my mistake?