PHP Startup: Unable to load dynamic library '/usr/local/php-5.5.21/lib/php/20121212/'


Anyone can help me to solve my problem, when i migrate my script to share hosting and the hosting use php version 5.5.21 i got this error meesage on all pages :

PHP Core Warning – yii\base\ErrorException

PHP Startup: Unable to load dynamic library ‘/usr/local/php-5.5.21/lib/php/20121212/’ - /usr/local/php-5.5.21/lib/php/20121212/ cannot open shared object file: No such file or directory

i tried to search in google but i didnt find the answer, i contacted the hosting no solution too, maybe someone have a solution for me,


Do you have a php.ini file that’s trying to load a zip extension?

Yes Keith, thanks for your reply, i checked my hosting by default setting php.ini is enable zip extension, when i disabled that extension the PROBLEM SOLVED … but on that server i have another application still using Yii1 i hope not impact to them

Thanks Keith …

This is a php startup error, php is trying to load but the file is not there.

If you can access php.ini probably you can also verify if the file is there

just do at command line

ls /usr/local/php-5.5.21/lib/php/20121212/

and probably you won’t see a file

You should not have any issue with yii1 since it has the same error but you do not see it (just look at apache log you’ll fine the error there).

Yii2 analyse also startup error, yii1 no.

Thanks for your advice Roberto